2018年7月15日日曜日

PS4 5.05~の本体で外付けhddにfpkgのゲームをインストールする方法

こちらの方法を試す前や質問をするまえに必ず下記リンクを見てからにしてください!
このブログについて
http://yyoossk.blogspot.jp/1970/11/blog-post_24.html

こちらでは5.05~のPS4本体で外付けhddにfpkgのゲームをインストールする方法を紹介します


注意
インストール用の外付けhddとインストールするfpkgを本体に読み込ませるためのフラッシュメモリ又は外付けhddの二つの記憶媒体が必要です


まず、外付けhddをps4本体に接続し、下記リンクを参考にps4で外付けhddをフォーマット
PS4で使用するUSBメモリーをexFATでフォーマット
http://www.ps4pro.jp/entry/2018/04/08/010000


アプリケーションのインストール場所を外付けhddに変更する
[設定]>[ストレージ]を選び、OPTIONS ボタンを押します。
[アプリケーションのインストール先]>[拡張ストレージ]を選びます。
以降、アプリケーションは拡張ストレージにインストールされます。


・PCからペイロードを送信
下記リンクより本体のバージョンにあったps4-hen-vtxをダウンロードしてください
※5.05~
https://github.com/xvortex/ps4-hen-vtx/releases
ps4-dumper.binのペイロードを下記リンクを参考にPS4に導入してください
WebKitExploit使用時にペイロードを読み込ませる方法(NetCat GUI)
自分でWebKitExploitをローカルサーバーでホストする方法(ps4-exploit-host)


・PS4本体のみでブラウザからps4-hen-vtxを起動
ブラウザからハックを可能にするウェブサイトまとめ


・esp8266経由でペイロードを起動する
こちらはツールを購入しないといけませんが、起動率が高く、安定しているので大変おすすめです
 
 
・PS4本体のみでオフラインでps4-hen-vtxを起動する
オフラインで安定してHEN等のペイロードを起動することができます
自分の環境では今のところメモリーエラーもなく起動率100%といっては過言ではないくらい安定してます




ps4-hen-vtxのペイロードを実行できたら、下記リンクを参考にフラッシュメモリ又は外付けhddからfpkgをインストールするだけです
Package Installerを使ったDRMfreeなPKG(更新パッチなど)インストール方法
https://yyoossk.blogspot.com/2018/01/ps4-package-installerdrmfreepkg.html

5 件のコメント:

  1. 質問させてください。

    FW5.05でHEN導入→PKGからインストールしたPS4ゲーム
    起動できたのですが、ゲームアップデートファイルは
    最新のFWにしないとインストールできないのでしょうか。

    PS4本体には、ゲームアップデートファイルがダウンロードできている状態で、
    手動でインストールを行おうとすると、最新のFWにしないとインストールできない旨、
    警告されてしまいます。

    FWをアップデートしなくても、ゲームアップデートファイルを
    インストールする方法はありますでしょうか?

    返信削除
    返信
    1. 今のところアップデータをダウンロードする方法はこちらしかありません
      https://yyoossk.blogspot.com/2018/01/ps4fw.html
      そのアップデータが対応するバージョンが書かれていると思います
      アップデータの要求バージョンはどんどんあがっていくためその前にダウンロードしておくしかありません
      現時点でアップデータが要求するバージョンより低い本体に入れられてもアップデート要求を回避する術はありませんので、その方法が出るまでは諦めてください

      削除
    2. ご教示ありがとうございます。
      既に旧バージョンのアップデータも5.06以上を求められたので
      インストールできませんでした。残念です。

      重ねて質問です。
      今までディスクから起動してプレイしていたものですが、
      この度、初のDUMP作業を行いました。
      CUSAxxxxx-appと、CUSAxxxxx-patchの両フォルダをpkg化し、
      HEN→インストールしましたが、既存のセーブデータをロードできませんでした。
      破損データとして扱われている状況です。

      ゲームデータのバージョンが一致しないと、
      既存のセーブデータはロードできないという認識でしたが、
      CUSAxxxxx-patchのフォルダもpkg化してインストールし
      すなわち、同じゲームデータのバージョンである環境を整えた
      つもりだったのですが…

      HENして起動した場合だと、既存のセーブデータを
      ロードさせてプレイすることはできないのでしょうか。

      削除
    3. すみませぬ
      自分まだそのようなケースに遭遇したことなくて
      時間のあるときに調べてもし分かったら記事にでもしてみます
      おそらく何らかの方法はあるとは思うのですが今はちょっと分かりません
      discordでもしかすると自分より詳しい方がいるかもしれないのでそちらで聞いてみるのもありかもしれませぬ
      お役に立てなくて申し訳ないっす

      削除
    4. お気遣いありがとうございます。
      参考までに、現状況とソフト名を晒します。

      ソフト名:GT〇5(CUSA00880:日本国内版)
      ゲームデータver.:1.16
      PS4FW:4.00→5.05

      手順としては以下の通りです。

      ゲームディスクと入れてゲームをバックグラウンドで起動

      ホームに戻り、ps4-exploit-host(v0.4.6a1)でDumperを起動

      外付けHDDに吸い出し後、PS4本体にインストールされていた
      ゲームデータを削除

      id.completeというファイルが生成されていることを確認

      gengp4.exe(v1.8)でCUSAxxxxx-appと、
      CUSAxxxxx-patchの両フォルダを読み込み、各.GP4を作成

      orbis-pub-gen.exe(v3.12)でPKG作成

      CUSAxxxxx-appのPKGをHEN起動でインストール

      この時点では、ゲームデータver.:1.00なので、
      セーブデータがロードされないのは納得。

      CUSAxxxxx-patchのPKGをHEN起動でインストール

      ゲームデータver.:1.16になっている事を確認。
      DUMPする前の環境を再現した。

      のはずが、相変わらずセーブデータがロードできない。
      破損していますと表示される。

      (´;ω;`)<ナンデ? ←今ここ

      このような感じです。
      進展ありましたら、情報共有お願い致します。

      削除